
<!DOCTYPE html>

<!--[if lt IE 7]><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# video: http://ogp.me/ns/video# ya: http://webmaster.yandex.ru/vocabularies/" class="no-js"><!--<![endif]-->

	<head>

		<meta charset="utf-8">

		<!-- Google Chrome Frame for IE -->
		<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script><![endif]-->
		<!-- mobile meta -->
                    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        
		<link rel="pingback" href="https://www.futurelooks.com/wordpress/xmlrpc.php">

		
		<!-- head functions -->
		<title>The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed - Futurelooks</title>
<script type="text/javascript">function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://www.futurelooks.com/wordpress/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://www.futurelooks.com/wordpress/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://www.futurelooks.com/wordpress/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 1, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssReduceHorizontalSvgHeight = true;var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}</script>			<style type="text/css">
					.heateor_sss_horizontal_sharing .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_horizontal_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_horizontal_sharing .heateorSssSharing:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_vertical_sharing .heateorSssSharing:hover{
						border-color: transparent;
		}
						div.heateor_sss_horizontal_sharing .heateorSssSharingSvg{height:70%;margin-top:5.25px}div.heateor_sss_horizontal_sharing .heateor_sss_square_count{line-height:6.65px;}
				@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}			</style>
			<script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed';
</script>


<link rel="canonical" href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/" />
<link rel="publisher" href="https://plus.google.com/+Futurelooksdotcom"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed - Futurelooks" />
<meta property="og:description" content="The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard ReviewedRemember the first K70 RGB keyboard from Corsair? This second-gen version is even better.ProsHigh quality constructionImproved media controlsEven better RGB than gen 1ConsTwo USB cables to plug inOnly one USB port2018-07-099.5Overall ScoreThe new and improved media controls, a wider volume roller, and dedicated buttons for adjusting the &hellip;" />
<meta property="og:url" content="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/" />
<meta property="og:site_name" content="Futurelooks" />
<meta property="article:publisher" content="https://www.facebook.com/futurelooks" />
<meta property="article:author" content="https://www.facebook.com/alarente" />
<meta property="article:tag" content="best mechanical keyboard" />
<meta property="article:tag" content="Corsair" />
<meta property="article:tag" content="Corsair Gaming" />
<meta property="article:tag" content="gaming keyboard" />
<meta property="article:tag" content="K70" />
<meta property="article:tag" content="K70 MK.2" />
<meta property="article:tag" content="Mechanical Keyboard" />
<meta property="article:tag" content="mechanical keyboard 2018" />
<meta property="article:tag" content="RGB Mechanical Keyboard" />
<meta property="article:tag" content="what keyboard to buy" />
<meta property="article:section" content="Reviews" />
<meta property="article:published_time" content="2018-07-09T11:07:25-07:00" />
<meta property="article:modified_time" content="2018-07-09T14:59:48-07:00" />
<meta property="og:updated_time" content="2018-07-09T14:59:48-07:00" />
<meta property="fb:admins" content="605860640" />
<meta property="og:image" content="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o.jpg" />
<meta property="og:image:secure_url" content="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard ReviewedRemember the first K70 RGB keyboard from Corsair? This second-gen version is even better.ProsHigh quality constructionImproved media controlsEven better RGB than gen 1ConsTwo USB cables to plug inOnly one USB port2018-07-099.5Overall ScoreThe new and improved media controls, a wider volume roller, and dedicated buttons for adjusting the [&hellip;]" />
<meta name="twitter:title" content="The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed - Futurelooks" />
<meta name="twitter:site" content="@futurelooks" />
<meta name="twitter:image" content="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o.jpg" />
<meta name="twitter:creator" content="@futurelooks" />
<meta property="DC.date.issued" content="2018-07-09T11:07:25-07:00" />


<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Futurelooks &raquo; Feed" href="https://www.futurelooks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Futurelooks &raquo; Comments Feed" href="https://www.futurelooks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Futurelooks &raquo; The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed Comments Feed" href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/feed/" />
<!-- managing ads with Advanced Ads --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><link rel='stylesheet' id='wphb-critical-css-css'  href='https://www.futurelooks.com/wordpress/wp-content/uploads/hummingbird-assets/1182dc25cb912238482599fbbd57f689.css' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/58a0f644-cdd9-483c-aaa6-5b4822a88811.css' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/201a8592-ce05-4a74-a924-885e23995529.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/0a5736b9-adfb-417d-990c-b43e5733a74c.css' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/2a6202c9-a90d-45a8-8389-1b7f13f0d3d5.css' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_sharing_default_svg-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/246d537d-c844-4771-bbbd-c5988d4fa5e9.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/1f1ffa82-9b73-427d-a726-b248cb8773f1.css' type='text/css' media='all' />
<link rel='stylesheet' id='cb-main-stylesheet-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/e309abfe-7c31-47ea-996d-9f3fa2378380.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='cb-ie-only-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/2eb1bcb2-7857-487f-b0c6-f6d43d8cea59.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='https://hb.wpmucdn.com/www.futurelooks.com/69d6e2dc-db55-4933-bb35-05f16cf4bf6d.css' type='text/css' media='all' />
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/75184836-2e4e-4a6b-ae67-ede0c5a679d0.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/30c6b580-382f-4084-beae-be34b268a8ef.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/fa72bd86-d80e-4907-a841-d3e5612141a1.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/ec2681af-0c69-416f-9b4b-9c02c4c101fb.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/5c3a4d12-cb39-4d77-8af5-bce5ca3595b1.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/b81aa846-34e9-4a49-b16e-7b3326ad6b21.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/cefa2115-0450-485b-b4dc-bc188494fe2f.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/23a0f735-78cc-48f1-978d-84ebbe232d92.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/58b177e7-ab95-487f-b34b-c5ee8de42e13.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/4c2497e6-c14d-4a45-9ff0-746c85f647d4.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WpDisableAsyncLinks = {"wp-disable-google-fonts":"\/\/fonts.googleapis.com\/css?family=Oswald:400,700,400italic|Open%20Sans:400,700,400italic&subset=greek,greek-ext"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/d3013c40-f521-4e29-b43f-2fb3d2af9417.js'></script>
<link rel="alternate" type="application/json+oembed" href="https://www.futurelooks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.futurelooks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F&#038;format=xml" />
		<style>
			.theiaPostSlider_nav.fontTheme ._title,
			.theiaPostSlider_nav.fontTheme ._text {
				line-height: 48px;
			}

			.theiaPostSlider_nav.fontTheme ._button {
				color: #1e73be;
			}

			.theiaPostSlider_nav.fontTheme ._button ._2 span {
				font-size: 48px;
				line-height: 48px;
			}

			.theiaPostSlider_nav.fontTheme ._button:hover,
			.theiaPostSlider_nav.fontTheme ._button:focus {
				color: #4497e1;
			}

			.theiaPostSlider_nav.fontTheme ._disabled {
				color: #6d6d6d !important;
			}
		</style>
	<!--[if IE]><script src="https://www.futurelooks.com/wordpress/wp-content/plugins/wp-gbcf/wp-gbcf_focus.js" type="text/javascript"></script><![endif]-->
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style>.cb-base-color, .cb-overlay-stars .fa-star, #cb-vote .fa-star, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, .bbp-submit-wrapper button:visited, .buddypress .cb-cat-header #cb-cat-title a,  .buddypress .cb-cat-header #cb-cat-title a:visited, .woocommerce .star-rating:before, .woocommerce-page .star-rating:before, .woocommerce .star-rating span, .woocommerce-page .star-rating span, .woocommerce .stars a {
            color:#1e73be;
        }#cb-search-modal .cb-header, .cb-join-modal .cb-header, .lwa .cb-header, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            border-color: #1e73be;
        }.cb-sidebar-widget .cb-sidebar-widget-title, .cb-multi-widget .tabbernav .tabberactive, .cb-author-page .cb-author-details .cb-meta .cb-author-page-contact, .cb-about-page .cb-author-line .cb-author-details .cb-meta .cb-author-page-contact, .cb-page-header, .cb-404-header, .cb-cat-header, #cb-footer #cb-widgets .cb-footer-widget-title span, #wp-calendar caption, .cb-tabs ul .current, .cb-tabs ul .ui-state-active, #bbpress-forums li.bbp-header, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li.selected, #buddypress div.item-list-tabs ul li.current, #buddypress .item-list-tabs ul li:hover, .woocommerce div.product .woocommerce-tabs ul.tabs li.active {
            border-bottom-color: #1e73be ;
        }#cb-main-menu .current-post-ancestor, #cb-main-menu .current-menu-item, #cb-main-menu .current-menu-ancestor, #cb-main-menu .current-post-parent, #cb-main-menu .current-menu-parent, #cb-main-menu .current_page_item, #cb-main-menu .current-page-ancestor, #cb-main-menu .current-category-ancestor, .cb-review-box .cb-bar .cb-overlay span, #cb-accent-color, .cb-highlight, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            background-color: #1e73be;
        }</style><!-- Body BG --><style>body { background-color: #ffffff;}</style><style type="text/css">
                                                 body, #respond { font-family: 'Open Sans', sans-serif; }
                                                 h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6, #cb-nav-bar #cb-main-menu ul li > a, .cb-author-posts-count, .cb-author-title, .cb-author-position, .search  .s, .cb-review-box .cb-bar, .cb-review-box .cb-score-box, .cb-review-box .cb-title, #cb-review-title, .cb-title-subtle, #cb-top-menu a, .tabbernav, #cb-next-link a, #cb-previous-link a, .cb-review-ext-box .cb-score, .tipper-positioner, .cb-caption, .cb-button, #wp-calendar caption, .forum-titles, .bbp-submit-wrapper button, #bbpress-forums li.bbp-header, #bbpress-forums fieldset.bbp-form .bbp-the-content-wrapper input, #bbpress-forums .bbp-forum-title, #bbpress-forums .bbp-topic-permalink, .widget_display_stats dl dt, .cb-lwa-profile .cb-block, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li, #buddypress .activity-list li.load-more, #buddypress a.activity-time-since, #buddypress ul#groups-list li div.meta, .widget.buddypress div.item-options, .cb-activity-stream #buddypress .activity-header .time-since, .cb-font-header, .woocommerce table.shop_table th, .woocommerce-page table.shop_table th, .cb-infinite-scroll a, .cb-no-more-posts { font-family:'Oswald', sans-serif; }
                     </style><style type="text/css">.entry-content a, .entry-content a:visited {color:#1e73be; }#cb-top-menu .cb-breaking-news ul li a { color:#1e73be; }</style><!-- end custom css --><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link rel="amphtml" href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/amp/"><style>#cb-nav-bar #cb-main-menu .main-nav .menu-item-24116:hover,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24116:focus,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24116 .cb-sub-menu li .cb-grandchild-menu,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24116 .cb-sub-menu { background:#1e73be!important; }
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-24116 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-43209:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43209:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43209 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43209 .cb-sub-menu { background:#1e73be!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43209 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24127:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24127:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24127 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24127 .cb-sub-menu { background:#1e73be!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24127 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24129:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24129:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24129 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24129 .cb-sub-menu { background:#1e73be!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24129 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-24201:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24201:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24201 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24201 .cb-sub-menu { background:#1e73be!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-24201 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-43051:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43051:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43051 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43051 .cb-sub-menu { background:#1e73be!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43051 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-43052:hover,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43052:focus,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43052 .cb-sub-menu li .cb-grandchild-menu,
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43052 .cb-sub-menu { background:#1e73be!important; }
                                             #cb-nav-bar #cb-main-menu .main-nav .menu-item-43052 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }
#cb-nav-bar #cb-main-menu .main-nav .menu-item-48459:hover,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-48459:focus,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-48459 .cb-sub-menu li .cb-grandchild-menu,
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-48459 .cb-sub-menu { background:#1e73be!important; }
                                         #cb-nav-bar #cb-main-menu .main-nav .menu-item-48459 .cb-mega-menu .cb-sub-menu li a { border-bottom-color:#1e73be!important; }</style><link rel="icon" href="https://www.futurelooks.com/wordpress/wp-content/uploads/2008/01/cropped-fl_logo_FL_wordmark_250x250-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.futurelooks.com/wordpress/wp-content/uploads/2008/01/cropped-fl_logo_FL_wordmark_250x250-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.futurelooks.com/wordpress/wp-content/uploads/2008/01/cropped-fl_logo_FL_wordmark_250x250-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.futurelooks.com/wordpress/wp-content/uploads/2008/01/cropped-fl_logo_FL_wordmark_250x250-270x270.jpg" />

<!-- BEGIN ExactMetrics v5.3.5 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-133589-1', 'auto', {'useAmpClientId': true});
  ga('require', 'displayfeatures');
  ga('require', 'linkid');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
		<!-- end head functions-->

	</head>

	<body class="post-template-default single single-post postid-49136 single-format-video  cb-sticky-mm cb-m-sticky cb-sb-nar-embed-fw cb-cat-t-dark cb-mobm-light cb-gs-style-d cb-modal-dark cb-light-blog cb-sidebar-right cb-boxed cb-fis-type-standard cb-fis-tl-st-default">

        
	    <div id="cb-outer-container">

            
            <!-- Small-Screen Menu -->
            
            <div id="cb-mob-menu" class="clearfix cb-light-menu">
                <a href="#" id="cb-mob-close" class="cb-link"><i class="fa cb-times"></i></a>

                                    <div class="cb-mob-menu-wrap">
                        <ul class="cb-small-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24116"><a href="http://www.futurelooks.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43209"><a href="https://www.futurelooks.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24127"><a href="https://www.futurelooks.com/category/review/">Reviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24129"><a href="https://www.futurelooks.com/category/guides/">Guides</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24201"><a href="https://www.futurelooks.com/category/video-reviews/">Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43051"><a href="https://www.futurelooks.com/category/shows-events/">Events</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43052"><a href="https://www.futurelooks.com/category/miscellaneous/">Extras</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48459"><a href="https://www.futurelooks.com/youtube-gallery/">YouTube</a></li>
</ul>                    </div>
                            </div>

            <!-- /Small-Screen Menu -->

                    <div id="cb-search-modal" class="cb-s-modal cb-modal cb-light-menu">
                        <div class="cb-search-box">
                            <div class="cb-header">
                                <div class="cb-title">Search</div>
                                <div class="cb-close">
                                    <span class="cb-close-modal cb-close-m"><i class="fa fa-times"></i></span>
                                </div>
                            </div><form role="search" method="get" class="cb-search" action="https://www.futurelooks.com/">

    <input type="text" class="cb-search-field" placeholder="" value="" name="s" title="">
    <button class="cb-search-submit" type="submit" value=""><i class="fa fa-search"></i></button>

</form></div></div>    		<div id="cb-container" class="wrap clearfix" itemprop="review" itemscope itemtype="http://schema.org/Review">

                <header class="header clearfix wrap">

                                            
                    
                        <div id="cb-logo-box" class="wrap clearfix">
                                            <div id="logo" class="cb-with-large">
                    <a href="https://www.futurelooks.com">
                        <img src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/02/fl_valenti_logo-1.png" alt="Futurelooks logo" >
                    </a>
                </div>
                                        <div class="cb-large cb-h-block cb-block"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FL Responsive Ad - Banner -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5855561270035832"
     data-ad-slot="8127793503"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>                        </div>

                     
                    

                                             <nav id="cb-nav-bar" class="clearfix cb-light-menu">
                            <div id="cb-main-menu" class="cb-nav-bar-wrap clearfix wrap">
                                <ul class="nav main-nav wrap clearfix"><li id="menu-item-24116" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-24116"><a href="http://www.futurelooks.com/">Home</a></li>
<li id="menu-item-43209" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43209"><a href="https://www.futurelooks.com/category/news/">News</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Random</span></div>
                                        <ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/diamond-multimedia-introduces-the-ue3000-usb-3-0-to-gigabit-ethernet-adapter/"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="480" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2013/07/Diamond_UE3000_1-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.futurelooks.com/diamond-multimedia-introduces-the-ue3000-usb-3-0-to-gigabit-ethernet-adapter/">Diamond Multimedia Introduces the UE3000 USB 3.0 to Gigabit Ethernet Adapter</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2013-07-15">July 15, 2013</time></div></div></div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/"><img title = "Futurelooks Bloody Optical Keyboards: The New Mechanical Option?  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/07/bloody_b930-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Bloody Optical Keyboards: The New Mechanical Option?  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/">Bloody Optical Keyboards: The New Mechanical Option?</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-04">July 4, 2018</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-buys-elgato-gaming/"><img title = "Futurelooks Corsair Buys Elgato Gaming  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/Screen-Shot-2018-06-27-at-3.20.02-PM-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Corsair Buys Elgato Gaming  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/corsair-buys-elgato-gaming/">Corsair Buys Elgato Gaming</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-30">June 30, 2018</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/create-an-asus-gaming-experience-with-tuf-gaming-products/"><img title = "Futurelooks Create an ASUS Gaming Experience with TUF Gaming Products  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180524150136_m1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Create an ASUS Gaming Experience with TUF Gaming Products  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/create-an-asus-gaming-experience-with-tuf-gaming-products/">Create an ASUS Gaming Experience with TUF Gaming Products</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-15">June 15, 2018</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/samsung-introduces-970-pro-evo-solid-state-drives/"><img title = "Futurelooks Samsung 970 EVO and 970 PRO Solid State Drives  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/ca-970-evo-nvme-m2-ssd-mz-v7e2t0bw-pkggroupshotblack-98270765-80x60.jpeg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Samsung 970 EVO and 970 PRO Solid State Drives  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/ca-970-evo-nvme-m2-ssd-mz-v7e2t0bw-pkggroupshotblack-98270765-80x60.jpeg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/ca-970-evo-nvme-m2-ssd-mz-v7e2t0bw-pkggroupshotblack-98270765-650x498.jpeg 650w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/ca-970-evo-nvme-m2-ssd-mz-v7e2t0bw-pkggroupshotblack-98270765-768x589.jpeg 768w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/ca-970-evo-nvme-m2-ssd-mz-v7e2t0bw-pkggroupshotblack-98270765.jpeg 892w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/samsung-introduces-970-pro-evo-solid-state-drives/">Samsung 970 EVO and 970 PRO Solid State Drives</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-13">June 13, 2018</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2018-geil-launches-super-luce-rgb-sync-series-tuf-gaming-memory/"><img title = "Futurelooks Computex 2018: GeIL Launches Super Luce RGB SYNC Series TUF Gaming Memory  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/GeIL_Super-Luce-RGB-Sync-Series-TUF-Gaming-Alliance_sideview-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Computex 2018: GeIL Launches Super Luce RGB SYNC Series TUF Gaming Memory  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/GeIL_Super-Luce-RGB-Sync-Series-TUF-Gaming-Alliance_sideview-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/GeIL_Super-Luce-RGB-Sync-Series-TUF-Gaming-Alliance_sideview-650x488.jpg 650w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/GeIL_Super-Luce-RGB-Sync-Series-TUF-Gaming-Alliance_sideview-768x576.jpg 768w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/GeIL_Super-Luce-RGB-Sync-Series-TUF-Gaming-Alliance_sideview.jpg 960w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/computex-2018-geil-launches-super-luce-rgb-sync-series-tuf-gaming-memory/">Computex 2018: GeIL Launches Super Luce RGB SYNC Series TUF Gaming Memory</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-12">June 12, 2018</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/rog-delta-rgb-gaming-headsets/"><img title = "Futurelooks ROG Delta Brings RGB to USB-C Gaming Headsets  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/usb-c-headset-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "ROG Delta Brings RGB to USB-C Gaming Headsets  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/rog-delta-rgb-gaming-headsets/">ROG Delta Brings RGB to USB-C Gaming Headsets</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-11">June 11, 2018</time></div></div></div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24127" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24127"><a href="https://www.futurelooks.com/category/review/">Reviews</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Random</span></div>
                                        <ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/anycom-bluetooth-solar-powered-handsfree-car-kit-sck-1-review/"><img src="https://www.futurelooks.com/wordpress/wp-content/themes/valenti/library/images/thumbnail-480x240.png" alt="article placeholder" data-at2x="https://www.futurelooks.com/wordpress/wp-content/themes/valenti/library/images/thumbnail-480x240@2x.png"></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.futurelooks.com/anycom-bluetooth-solar-powered-handsfree-car-kit-sck-1-review/">Anycom Bluetooth Solar Powered Handsfree Car-Kit SCK-1 Review</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2008-02-11">February 11, 2008</time></div></div></div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/">The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-09">July 9, 2018</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/steelseries-rival-110-gaming-mouse-review/"><img title = "Futurelooks SteelSeries Rival 110 Gaming Mouse Review  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180630-7758-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "SteelSeries Rival 110 Gaming Mouse Review  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9</span><span class="cb-score-title"></span></div></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/steelseries-rival-110-gaming-mouse-review/">SteelSeries Rival 110 Gaming Mouse Review</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-02">July 2, 2018</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-hs70-wireless-gaming-headset-review/"><img title = "Futurelooks Corsair HS70 Wireless Gaming Headset Review  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Corsair HS70 Wireless Gaming Headset Review  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/corsair-hs70-wireless-gaming-headset-review/">Corsair HS70 Wireless Gaming Headset Review</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-21">June 21, 2018</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-k63-wireless-mechanical-keyboard-review/"><img title = "Futurelooks Corsair K63 Wireless Mechanical Keyboard Review  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180502-6901-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Corsair K63 Wireless Mechanical Keyboard Review  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/corsair-k63-wireless-mechanical-keyboard-review/">Corsair K63 Wireless Mechanical Keyboard Review</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-05-10">May 10, 2018</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/patriot-viper-v570-blackout-edition-gaming-mouse-review/"><img title = "Futurelooks Patriot Viper V570 Blackout Edition Gaming Mouse Review  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2017/09/20180303-6311-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Patriot Viper V570 Blackout Edition Gaming Mouse Review  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/patriot-viper-v570-blackout-edition-gaming-mouse-review/">Patriot Viper V570 Blackout Edition Gaming Mouse Review</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-04-06">April 6, 2018</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-k70-rgb-mechanical-gaming-keyboard-review/"><img title = "Futurelooks Corsair K70 RGB Mechanical Gaming Keyboard Review  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/03/corsair-3881-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Corsair K70 RGB Mechanical Gaming Keyboard Review  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/corsair-k70-rgb-mechanical-gaming-keyboard-review/">Corsair K70 RGB Mechanical Gaming Keyboard Review</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-03-22">March 22, 2018</time></div></div></div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24129" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24129"><a href="https://www.futurelooks.com/category/guides/">Guides</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Random</span></div>
                                        <ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/futurelooks-2014-holiday-gift-guide-pc-diy-enthusiasts/"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="480" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2010/12/retrogifts-1-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2010/12/retrogifts-1-480x240.jpg 480w, https://www.futurelooks.com/wordpress/wp-content/uploads/2010/12/retrogifts-1-500x250.jpg 500w" sizes="(max-width: 480px) 100vw, 480px" /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.futurelooks.com/futurelooks-2014-holiday-gift-guide-pc-diy-enthusiasts/">A Futurelooks 2014 Holiday Gift Guide for the PC DIY Enthusiasts on Your List</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-12-15">December 15, 2014</time></div></div></div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/holiday-gift-guide-pc-gamers/"><img title = "Futurelooks Holiday Gift Guide: Unorthodox Ideas for PC Gamers (for Under $100)  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/12/pc-gamer-christmas-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Holiday Gift Guide: Unorthodox Ideas for PC Gamers (for Under $100)  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/holiday-gift-guide-pc-gamers/">Holiday Gift Guide: Unorthodox Ideas for PC Gamers (for Under $100)</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-12-06">December 6, 2016</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/delete-old-windows-files/"><img title = "Futurelooks How to Get Rid of Your Old Windows Files After Upgrading to Windows 10  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/08/windows-old-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "How to Get Rid of Your Old Windows Files After Upgrading to Windows 10  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/delete-old-windows-files/">How to Get Rid of Your Old Windows Files After Upgrading to Windows 10</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2015-08-21">August 21, 2015</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/need-know-todays-windows-10-event/"><img title = "Futurelooks What You Need to Know from Today&#039;s Windows 10 Event  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/01/windows-10-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "What You Need to Know from Today&#039;s Windows 10 Event  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/01/windows-10-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2015/01/windows-10-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/need-know-todays-windows-10-event/">What You Need to Know from Today's Windows 10 Event</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2015-01-21">January 21, 2015</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/three-things-dont-like-far-windows-10/"><img title = "Futurelooks Five Things We Don&#039;t Like (So Far) About Windows 10  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Five Things We Don&#039;t Like (So Far) About Windows 10  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/three-things-dont-like-far-windows-10/">Five Things We Don't Like (So Far) About Windows 10</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-10-07">October 7, 2014</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/windows-10-preview-good-part-1/"><img title = "Futurelooks Five Things We Like (So Far) About Windows 10  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview_-What-We-Liked-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Five Things We Like (So Far) About Windows 10  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview_-What-We-Liked-3-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview_-What-We-Liked-3-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/windows-10-preview-good-part-1/">Five Things We Like (So Far) About Windows 10</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-10-02">October 2, 2014</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/apples-mac-pro-2013-edition-owcs-larry-oconnor-lays-law-diy-upgrades/"><img title = "Futurelooks Apple&#039;s Mac Pro 2013 Edition - OWC&#039;s Larry O&#039;Connor Lays Down the Law on DIY Upgrades (Video)  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/01/owc_interview_ces2014-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Apple&#039;s Mac Pro 2013 Edition - OWC&#039;s Larry O&#039;Connor Lays Down the Law on DIY Upgrades (Video)  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/01/owc_interview_ces2014-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2014/01/owc_interview_ces2014-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/apples-mac-pro-2013-edition-owcs-larry-oconnor-lays-law-diy-upgrades/">Apple's Mac Pro 2013 Edition - OWC's Larry O'Connor Lays Down the Law on DIY Upgrades (Video)</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-01-31">January 31, 2014</time></div></div></div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-24201" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24201"><a href="https://www.futurelooks.com/category/video-reviews/">Videos</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Random</span></div>
                                        <ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2011-video-coverage-gigabyte-unveils-cheaper-g1-killer-msata-ready-intel-z68-boards-and-a-sneak-peek-at-the-intel-x79-lga2011-prototype/"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="480" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2011/06/intel_gigabyte_lga2011-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.futurelooks.com/computex-2011-video-coverage-gigabyte-unveils-cheaper-g1-killer-msata-ready-intel-z68-boards-and-a-sneak-peek-at-the-intel-x79-lga2011-prototype/">COMPUTEX 2011 Video Coverage - GIGABYTE Unveils Cheaper G1-Killer, mSATA Ready INTEL Z68 boards, and a Sneak Peek at the INTEL X79 LGA2011 Prototype</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2011-06-12">June 12, 2011</time></div></div></div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/">The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-09">July 9, 2018</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/vlog-2-intel-x58-system-wont-die/"><img title = "Futurelooks Vlog #2 - The Intel X58 System That Won&#039;t Die  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2017/07/kchdnznvpvc-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Vlog #2 - The Intel X58 System That Won&#039;t Die  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/vlog-2-intel-x58-system-wont-die/">Vlog #2 - The Intel X58 System That Won't Die</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2017-07-17">July 17, 2017</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/vlog-1-networking-event/"><img title = "Futurelooks Vlog #1 - A Networking Event Featuring TP-Link  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2017/05/20170524-9952-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Vlog #1 - A Networking Event Featuring TP-Link  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/vlog-1-networking-event/">Vlog #1 - A Networking Event Featuring TP-Link</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2017-05-01">May 1, 2017</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/ecs-liva-x-mini-pc-unboxed-video/"><img title = "Futurelooks ECS LIVA X Mini PC Unboxed (Video)  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/05/fl_liva_x_unboxing.00_02_53_19.Still015-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "ECS LIVA X Mini PC Unboxed (Video)  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/ecs-liva-x-mini-pc-unboxed-video/">ECS LIVA X Mini PC Unboxed (Video)</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2015-05-11">May 11, 2015</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/kingston-hyperx-predator-pcie-hhhl-ssd-unboxed-video/"><img title = "Futurelooks Kingston HyperX Predator PCIe 480GB HHHL SSD Unboxed (Video)  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/05/Main.00_00_22_08.Still002-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Kingston HyperX Predator PCIe 480GB HHHL SSD Unboxed (Video)  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/kingston-hyperx-predator-pcie-hhhl-ssd-unboxed-video/">Kingston HyperX Predator PCIe 480GB HHHL SSD Unboxed (Video)</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2015-05-04">May 4, 2015</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/lacie-rugged-raid-4tb-thunderbolt-portable-drive-unboxed-video/"><img title = "Futurelooks LaCie Rugged RAID 4TB Thunderbolt Portable Drive Unboxed! (Video)  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/04/Main.00_04_57_03.Still001-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "LaCie Rugged RAID 4TB Thunderbolt Portable Drive Unboxed! (Video)  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/lacie-rugged-raid-4tb-thunderbolt-portable-drive-unboxed-video/">LaCie Rugged RAID 4TB Thunderbolt Portable Drive Unboxed! (Video)</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2015-04-27">April 27, 2015</time></div></div></div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-43051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43051"><a href="https://www.futurelooks.com/category/shows-events/">Events</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Random</span></div>
                                        <ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2012-nzxt-unveils-new-notebook-coolers-and-a-new-phantom/"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="480" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2012/06/computex2012_nzxt-6-480x240.jpg" class="attachment-cb-480-240 size-cb-480-240 wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " /></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.futurelooks.com/computex-2012-nzxt-unveils-new-notebook-coolers-and-a-new-phantom/">COMPUTEX 2012 - NZXT Unveils New Notebook Coolers and a New Phantom!</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2012-06-14">June 14, 2012</time></div></div></div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/napa-press-event-gigabyte-corsair-intel/"><img title = "Futurelooks Napa Valley Press Event: Gigabyte, Corsair and Intel Putting Gamers First  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/07/napa-valley-2016-19-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Napa Valley Press Event: Gigabyte, Corsair and Intel Putting Gamers First  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/napa-press-event-gigabyte-corsair-intel/">Napa Valley Press Event: Gigabyte, Corsair and Intel Putting Gamers First</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-07-07">July 7, 2016</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2016-crazy-case-modders-showcased-gigabyte/"><img title = "Futurelooks Computex 2016: Crazy Case Modders Showcased by GIGABYTE  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/gigabyte-case-modders-1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Computex 2016: Crazy Case Modders Showcased by GIGABYTE  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/computex-2016-crazy-case-modders-showcased-gigabyte/">Computex 2016: Crazy Case Modders Showcased by GIGABYTE</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-18">June 18, 2016</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2016-streacom-db2/"><img title = "Futurelooks Computex 2016: Streacom DB2 Announced Second, but Not Necessarily Second Best  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db2-pro-025-325-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Computex 2016: Streacom DB2 Announced Second, but Not Necessarily Second Best  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db2-pro-025-325-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db2-pro-025-325-650x488.jpg 650w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db2-pro-025-325-768x576.jpg 768w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db2-pro-025-325.jpg 1200w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db2-pro-025-325-200x150.jpg 200w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db2-pro-025-325-600x450.jpg 600w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/computex-2016-streacom-db2/">Computex 2016: Streacom DB2 Announced Second, but Not Necessarily Second Best</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-12">June 12, 2016</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2016-streacom-db4/"><img title = "Futurelooks Computex 2016: Streacom DB4 Is a Cubist&#039;s Dream  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db4-000-000-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Computex 2016: Streacom DB4 Is a Cubist&#039;s Dream  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db4-000-000-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db4-000-000-650x488.jpg 650w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db4-000-000-768x576.jpg 768w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db4-000-000.jpg 1200w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db4-000-000-200x150.jpg 200w, https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/db4-000-000-600x450.jpg 600w" sizes="(max-width: 80px) 100vw, 80px" /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/computex-2016-streacom-db4/">Computex 2016: Streacom DB4 Is a Cubist's Dream</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-06">June 6, 2016</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2016-thermaltake-core-p3/"><img title = "Futurelooks Computex 2016: The Writing&#039;s on the Wall for Thermaltake&#039;s New Core P3 Chassis  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/Thermaltake-New-Core-P3-ATX-Wall-Mount-Panoramic-Viewing-Chassis-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Computex 2016: The Writing&#039;s on the Wall for Thermaltake&#039;s New Core P3 Chassis  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/computex-2016-thermaltake-core-p3/">Computex 2016: The Writing's on the Wall for Thermaltake's New Core P3 Chassis</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-03">June 3, 2016</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/computex-2016-deepcool-keeps-things-cool-stifle-giggle-name/"><img title = "Futurelooks Computex 2016: DEEPCOOL Keeps Things Cool While We Stifle a Giggle  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/DEEPCOOLGenome-ROG-Certified-Edition-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Computex 2016: DEEPCOOL Keeps Things Cool While We Stifle a Giggle  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/computex-2016-deepcool-keeps-things-cool-stifle-giggle-name/">Computex 2016: DEEPCOOL Keeps Things Cool While We Stifle a Giggle</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-01">June 1, 2016</time></div></div></div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-43052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43052"><a href="https://www.futurelooks.com/category/miscellaneous/">Extras</a><div class="cb-big-menu"><div class="cb-articles">
                                    <div class="cb-featured">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Random</span></div>
                                        <ul><li class="cb-article cb-relative cb-grid-entry cb-style-overlay clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/mobile-edge-scanfast-checkpoint-friendly-laptop-backpack-review/"><img src="https://www.futurelooks.com/wordpress/wp-content/themes/valenti/library/images/thumbnail-480x240.png" alt="article placeholder" data-at2x="https://www.futurelooks.com/wordpress/wp-content/themes/valenti/library/images/thumbnail-480x240@2x.png"></a></div><div class="cb-meta cb-article-meta"><h2 class="cb-post-title"><a href="https://www.futurelooks.com/mobile-edge-scanfast-checkpoint-friendly-laptop-backpack-review/">Mobile Edge ScanFast Checkpoint Friendly Laptop Backpack Review</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2009-04-26">April 26, 2009</time></div></div></div></li></ul>
                                     </div>
                                     <div class="cb-recent cb-recent-fw">
                                        <div class="cb-mega-title h2"><span style="border-bottom-color:#1e73be;">Recent</span></div>
                                        <ul> <li class="cb-article-1 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/taiwans-digital-dreams-may-not-be-realized-in-hardware/"><img title = "Futurelooks Taiwan&#039;s Digital Dreams May Not Be Realized in Hardware  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2017/12/taiwan_4-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Taiwan&#039;s Digital Dreams May Not Be Realized in Hardware  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/taiwans-digital-dreams-may-not-be-realized-in-hardware/">Taiwan's Digital Dreams May Not Be Realized in Hardware</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2017-12-03">December 3, 2017</time></div></div></div></li> <li class="cb-article-2 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/sponsored-html5-really-mean-2016/"><img title = "Futurelooks What Does HTML5 Really Mean in 2016?  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/nubuntu-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "What Does HTML5 Really Mean in 2016?  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/sponsored-html5-really-mean-2016/">What Does HTML5 Really Mean in 2016?</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-07-05">July 5, 2016</time></div></div></div></li> <li class="cb-article-3 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/focus-taiwan-cooler-master-embraces-trendy-vr-maker-culture-latest-products/"><img title = "Futurelooks A Focus on Taiwan - Cooler Master Embraces Trendy VR and Maker Culture in Latest Products  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/07/TAITRA_COOLERMASTER2016-1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "A Focus on Taiwan - Cooler Master Embraces Trendy VR and Maker Culture in Latest Products  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/focus-taiwan-cooler-master-embraces-trendy-vr-maker-culture-latest-products/">A Focus on Taiwan - Cooler Master Embraces Trendy VR and Maker Culture in Latest Products</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-07-05">July 5, 2016</time></div></div></div></li> <li class="cb-article-4 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/pc-gaming-culture-thrives-at-tt-esports/"><img title = "Futurelooks A Focus on Taiwan - PC Gaming Culture Thrives at Thermaltake through Tt eSports  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/TAITRA_ttesports_2016-11-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "A Focus on Taiwan - PC Gaming Culture Thrives at Thermaltake through Tt eSports  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/pc-gaming-culture-thrives-at-tt-esports/">A Focus on Taiwan - PC Gaming Culture Thrives at Thermaltake through Tt eSports</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-19">June 19, 2016</time></div></div></div></li> <li class="cb-article-5 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/in-win-unique-designs-making-modding-dreams/"><img title = "Futurelooks A Focus on Taiwan - In Win Doubles Down on Unique Designs and Modding Dreams  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/TAITRA_INWIN2016-4-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "A Focus on Taiwan - In Win Doubles Down on Unique Designs and Modding Dreams  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/in-win-unique-designs-making-modding-dreams/">A Focus on Taiwan - In Win Doubles Down on Unique Designs and Modding Dreams</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-14">June 14, 2016</time></div></div></div></li> <li class="cb-article-6 clearfix"><div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/focus-taiwan-gigabyte-puts-gaming-notebooks-without-extra-calories/"><img title = "Futurelooks A Focus on Taiwan - GIGABYTE Puts Gaming in Notebooks Without Extra Calories  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/06/TAITRA_GBT2016-1-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "A Focus on Taiwan - GIGABYTE Puts Gaming in Notebooks Without Extra Calories  " /></a></div><div class="cb-meta"><h2 class="h4"><a href="https://www.futurelooks.com/focus-taiwan-gigabyte-puts-gaming-notebooks-without-extra-calories/">A Focus on Taiwan - GIGABYTE Puts Gaming in Notebooks Without Extra Calories</a></h2><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-06-13">June 13, 2016</time></div></div></div></li></ul>
                                     </div>
                                 </div></div></li>
<li id="menu-item-48459" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48459"><a href="https://www.futurelooks.com/youtube-gallery/">YouTube</a></li>
<li class="cb-icons"><ul id="cb-icons-wrap"><li class="cb-icon-search cb-menu-icon"><a href="#" data-cb-tip="Search" class="cb-tip-bot" id="cb-s-trigger"><i class="fa fa-search"></i></a></li></ul></li></ul>                            </div>
                        </nav>
                    
	 				
                                <!-- Secondary Menu -->
        <div id="cb-top-menu" class="clearfix cb-light-menu">
            <div class="wrap cb-top-menu-wrap clearfix">

                <div class="cb-left-side cb-mob">
                                            <a href="#" id="cb-mob-open"><i class="fa fa-bars"></i></a>
                    <div class="cb-breaking-news cb-font-header"><span>Trending <i class="fa fa-long-arrow-right"></i></span><ul id="cb-ticker"><li><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/" title="Bloody Optical Keyboards: The New Mechanical Option?">Bloody Optical Keyboards: The New Mechanical Option?</a></li><li><a href="https://www.futurelooks.com/corsair-buys-elgato-gaming/" title="Corsair Buys Elgato Gaming">Corsair Buys Elgato Gaming</a></li><li><a href="https://www.futurelooks.com/create-an-asus-gaming-experience-with-tuf-gaming-products/" title="Create an ASUS Gaming Experience with TUF Gaming Products">Create an ASUS Gaming Experience with TUF Gaming Products</a></li><li><a href="https://www.futurelooks.com/samsung-introduces-970-pro-evo-solid-state-drives/" title="Samsung 970 EVO and 970 PRO Solid State Drives">Samsung 970 EVO and 970 PRO Solid State Drives</a></li></ul></div></div><div class="cb-mob-right"><a href="#" class="cb-small-menu-icons cb-small-menu-search" id="cb-s-trigger-sm"><i class="fa fa-search"></i></a></div>
            </div>
        </div>
        <!-- /Secondary Menu -->

                    
                    
	 				      <a href="#" id="cb-to-top" class="cb-base-color"><i class="fa fa-long-arrow-up"></i></a>

                    
                </header> <!-- end header --><div class="cb-breadcrumbs wrap"><a href="https://www.futurelooks.com">Home</a><i class="fa fa-angle-right"></i><div itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.futurelooks.com/category/review/" title="View all posts in Reviews" itemprop="url"><span itemprop="title">Reviews</span></a></div></div>            <div id="cb-content" class="wrap clearfix">

                
    <meta itemprop="datePublished" content="2018-07-09T11:07:25+00:00">
    <meta itemprop="dateModified" content="2018-07-09T14:59:48+00:00">
    <meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/">
    <span class="cb-hide" itemscope itemprop="publisher" itemtype="https://schema.org/Organization">
        <meta itemprop="name" content="Futurelooks">
        <meta itemprop="url" content="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/02/fl_valenti_logo-1.png">
        <span class="cb-hide" itemscope itemprop="logo" itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/02/fl_valenti_logo-1.png">
        </span>
    </span>
    <span class="cb-hide" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Alex Larente"></span>

    <meta itemprop="headline" content="The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed">

      <span class="cb-hide" itemscope itemtype="http://schema.org/ImageObject" itemprop="image" >
        <meta itemprop="url" content="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o.jpg">
        <meta itemprop="width" content="1200">
        <meta itemprop="height" content="675">
    </span>


				<div id="main" class="cb-main clearfix">

						<article id="post-49136" class="clearfix post-49136 post type-post status-publish format-video has-post-thumbnail category-review category-video-reviews tag-best-mechanical-keyboard tag-corsair tag-corsair-gaming tag-gaming-keyboard tag-k70 tag-k70-mk-2 tag-mechanical-keyboard tag-mechanical-keyboard-2018 tag-rgb-mechanical-keyboard tag-what-keyboard-to-buy post_format-post-format-video">

                             <header id="cb-standard-featured"><div class="cb-mask"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="750" height="400" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o-750x400.jpg" class="cb-fi-standard wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " /><div id="cb-m-trigger" class="cb-media-icon"><i class="fa fa-play"></i></div><div id="cb-media-overlay" class="cb-video-overlay"><div class="cb-close-m cb-ta-right"><i class="fa cb-times"></i></div><div id="cb-yt-player">jYPh4j8XSDA</div></div></div><div id="cb-fis-wrap" class="cb-entry-header hentry cb-fis cb-style-standard"><span class="cb-title-fi"><h1 class="entry-title cb-entry-title cb-single-title" itemprop="headline">The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed</h1><div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="updated" datetime="2018-07-09">July 9, 2018</time></div></div></div></header>
							<section class="cb-entry-content entry-content clearfix" itemprop="reviewBody">

								<div id="cb-review-container" class="cb-review-box cb-top-review-box cb-editor clearfix"><div id="cb-review-title" itemprop="itemReviewed" class="entry-title">The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed</div><div class="cb-summary"><div id="cb-conclusion">Remember the first K70 RGB keyboard from Corsair? This second-gen version is even better.</div></div><div class="cb-pros-cons cb-pros-list"><div class="cb-title">Pros</div><ul><li>High quality construction</li><li>Improved media controls</li><li>Even better RGB than gen 1</li></ul></div><div class="cb-pros-cons cb-cons-list"><div class="cb-title">Cons</div><ul><li>Two USB cables to plug in</li><li>Only one USB port</li></ul></div><time class="cb-hide" datetime="2018-07-09">2018-07-09</time><div class="cb-score-box clearfix" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><meta itemprop="worstRating" content="0"><meta itemprop="bestRating" content="10"><span class="score" itemprop="ratingValue">9.5</span><span class="score-title">Overall Score</span></div></div><!-- /cb-review-box --><p><!-- BEGIN THEIA POST SLIDER --></p>
<p>The new and improved media controls, a wider volume roller, and dedicated buttons for adjusting the RGB profiles are welcome changes to the <a href="https://www.futurelooks.com/corsair-k70-rgb-mechanical-gaming-keyboard-review/">Corsair K70 keyboard</a>. The new Corsair K70 MK.2 model adds underside cable routing channels for additional cable management and small changes in the palm rest textures that adds extra grip.</p>
<p>The most important factor in purchasing a mechanical keyboard is the quality of its switches. Picking between Cherry MX keys like Red, Blue, and Silent will make a big difference to how the keyboard feels. The Blue switches on this model, for example, are loud and clicky. The Cherry MX Red switches, however, are smooth and without an audible click. Your preference is important here. Also included are a set of gaming style keycaps that have a curved grip rather than flat.</p><div class="futur-fl-in-content" id="futur-1096293517"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-5855561270035832" data-ad-slot="4373881554"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><br style="clear: both; display: block; float: none;"><br style="clear: both; display: block; float: none; color:blue;">
<p><img title="Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180612_074134-1-650x488.jpg" alt="The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " width="650" height="488" class="aligncenter size-medium wp-image-49151" srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180612_074134-1-650x488.jpg 650w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180612_074134-1-768x576.jpg 768w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180612_074134-1.jpg 1200w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180612_074134-1-80x60.jpg 80w" sizes="(max-width: 650px) 100vw, 650px"></p>
<h2>Design Improvements</h2>
<p>The K70 still has the same two USB cables, which was my biggest complaint about the previous model, but the new profile button, standout media controls, and wider volume roller are big improvements. I also enjoy the addition of RGB lighting to the Corsair logo.</p>
<p>The Corsair K70 MK.2 is everything the original was — but better. It’s great to see Corsair making improvements to a beloved product without losing anything in the process.</p>
<h2>Should You Buy a K70 MK.2?</h2>
<p>If you already own a K70, this may not be the upgrade for you. But if you are looking for a new keyboard with full RGB support, great switches, beautiful controls, and at a good price (starting at $229 CAD), the Corsair <a href="https://www.corsair.com/ca/en/Categories/Products/Gaming-Keyboards/RGB-Mechanical-Gaming-Keyboards/K70-RGB-MK-2/p/CH-9109010-NA">K70 MK.2</a> is for you.</p>
<p class="jetpack-slideshow-noscript robots-nocontent">This slideshow requires JavaScript.</p><div id="gallery-49136-2-slideshow" class="slideshow-window jetpack-slideshow slideshow-black" data-trans="fade" data-autostart="1" data-gallery='[{"src":"https:\/\/www.futurelooks.com\/wordpress\/wp-content\/uploads\/2018\/06\/Screen-Shot-2018-06-13-at-2.46.00-PM.jpg","id":"49138","title":"Screen Shot 2018-06-13 at 2.46.00 PM","alt":"","caption":"New RGB profile button","itemprop":"image"},{"src":"https:\/\/www.futurelooks.com\/wordpress\/wp-content\/uploads\/2018\/06\/mwrkmisnp-o.jpg","id":"49142","title":"Video thumbnail for youtube video mwrkmisnp-o","alt":"","caption":"Two USB cables","itemprop":"image"},{"src":"https:\/\/www.futurelooks.com\/wordpress\/wp-content\/uploads\/2018\/06\/20180612_074134.jpg","id":"49140","title":"20180612_074134","alt":"","caption":"Updated hand rest","itemprop":"image"},{"src":"https:\/\/www.futurelooks.com\/wordpress\/wp-content\/uploads\/2018\/06\/Screen-Shot-2018-06-13-at-2.45.49-PM.jpg","id":"49139","title":"Screen Shot 2018-06-13 at 2.45.49 PM","alt":"","caption":"Wider volume controls","itemprop":"image"},{"src":"https:\/\/www.futurelooks.com\/wordpress\/wp-content\/uploads\/2018\/06\/5aadahfkn-o.jpg","id":"49152","title":"Video thumbnail for youtube video 5aadahfkn-o","alt":"","caption":"RGB Lighting","itemprop":"image"}]' itemscope itemtype="https://schema.org/ImageGallery"></div>
<p><!-- END THEIA POST SLIDER --></p>
<div class="heateorSssClear"></div><div class="heateor_sss_sharing_container heateor_sss_horizontal_sharing" heateor-sss-data-href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+Futurelooks+%28FutureLooks+-+Stuff+For+People+Who+Like+Computers%21%29"><div class="heateor_sss_sharing_title" style="font-weight:bold">Share This With The World!</div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Facebook" title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BFuturelooks%2B%2528FutureLooks%2B-%2BStuff%2BFor%2BPeople%2BWho%2BLike%2BComputers%2521%2529")'><ss style="display:block;margin-top:0;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss><ss class="heateor_sss_square_count heateor_sss_facebook_count" style="visibility:visible;display:block;">3</ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Instagram" title="Instagram" class="heateorSssSharing heateorSssInstagramBackground"><a href="https://www.instagram.com/" target="_blank"><ss style="display:block;" class="heateorSssSharingSvg heateorSssInstagramSvg"></ss><ss class="heateor_sss_square_count heateor_sss_instagram_count"> </ss></a></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Twitter" title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?via=futurelooks&amp;text=The%20CORSAIR%20K70%20MK.2%20Mechanical%20RGB%20Gaming%20Keyboard%20Reviewed&amp;url=https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BFuturelooks%2B%2528FutureLooks%2B-%2BStuff%2BFor%2BPeople%2BWho%2BLike%2BComputers%2521%2529")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss><ss class="heateor_sss_square_count heateor_sss_twitter_count"> </ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Pinterest" title="Pinterest" class="heateorSssSharing heateorSssPinterestBackground" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;" class="heateorSssSharingSvg heateorSssPinterestSvg"></ss><ss class="heateor_sss_square_count heateor_sss_pinterest_count"> </ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Reddit" title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BFuturelooks%2B%2528FutureLooks%2B-%2BStuff%2BFor%2BPeople%2BWho%2BLike%2BComputers%2521%2529&amp;title=The%20CORSAIR%20K70%20MK.2%20Mechanical%20RGB%20Gaming%20Keyboard%20Reviewed")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss><ss class="heateor_sss_square_count heateor_sss_reddit_count"> </ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Whatsapp" title="Whatsapp" class="heateorSssSharing heateorSssWhatsappBackground"><a href="https://api.whatsapp.com/send?text=The%20CORSAIR%20K70%20MK.2%20Mechanical%20RGB%20Gaming%20Keyboard%20Reviewed%20https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BFuturelooks%2B%2528FutureLooks%2B-%2BStuff%2BFor%2BPeople%2BWho%2BLike%2BComputers%2521%2529" rel="nofollow"><ss style="display:block" class="heateorSssSharingSvg heateorSssWhatsappSvg"></ss><ss class="heateor_sss_square_count heateor_sss_whatsapp_count"> </ss></a></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Buffer" title="Buffer" class="heateorSssSharing heateorSssBufferBackground" onclick='heateorSssPopup("https://buffer.com/add?url=https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BFuturelooks%2B%2528FutureLooks%2B-%2BStuff%2BFor%2BPeople%2BWho%2BLike%2BComputers%2521%2529&amp;title=The%20CORSAIR%20K70%20MK.2%20Mechanical%20RGB%20Gaming%20Keyboard%20Reviewed")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssBufferSvg"></ss><ss class="heateor_sss_square_count heateor_sss_buffer_count"> </ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Stumbleupon" title="Stumbleupon" class="heateorSssSharing heateorSssStumbleuponBackground" onclick='heateorSssPopup("http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BFuturelooks%2B%2528FutureLooks%2B-%2BStuff%2BFor%2BPeople%2BWho%2BLike%2BComputers%2521%2529&amp;title=The%20CORSAIR%20K70%20MK.2%20Mechanical%20RGB%20Gaming%20Keyboard%20Reviewed")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssStumbleuponSvg"></ss><ss class="heateor_sss_square_count heateor_sss_stumbleupon_count"> </ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;" alt="Google Gmail" title="Google Gmail" class="heateorSssSharing heateorSssGoogleGmailBackground" onclick='heateorSssPopup("https://mail.google.com/mail/?ui=2&amp;view=cm&amp;fs=1&amp;tf=1&amp;su=The%20CORSAIR%20K70%20MK.2%20Mechanical%20RGB%20Gaming%20Keyboard%20Reviewed&amp;body=Link:https%3A%2F%2Fwww.futurelooks.com%2Fcorsair-k70-mk2-keyboard-review%2F%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BFuturelooks%2B%2528FutureLooks%2B-%2BStuff%2BFor%2BPeople%2BWho%2BLike%2BComputers%2521%2529")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssGoogleGmailSvg"></ss><ss class="heateor_sss_square_count heateor_sss_Google_Gmail_count"> </ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count"> </ss><i style="width:35px;height:35px;" title="More" alt="More" class="heateorSssSharing heateorSssMoreBackground" onclick="heateorSssMoreSharingPopup(this, 'https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+Futurelooks+%28FutureLooks+-+Stuff+For+People+Who+Like+Computers%21%29', 'The%20CORSAIR%20K70%20MK.2%20Mechanical%20RGB%20Gaming%20Keyboard%20Reviewed', '' )"><ss style="display:block" class="heateorSssSharingSvg heateorSssMoreSvg"></ss></i></li><li class="heateorSssSharingRound"><ss class="heateor_sss_square_count"> </ss><i style="width:35px;height:35px;margin-left:9px !important;visibility:visible;" title="Total Shares" class="heateorSssSharing heateorSssTCBackground"><div class="heateorSssTotalShareCount" style="font-size: 21.7px">3</div><div class="heateorSssTotalShareText" style="font-size: 13.3px">Shares</div></i></li></ul><div class="heateorSssClear"></div></div><div class="heateorSssClear"></div>

							</section> <!-- end article section -->

							<footer class="article-footer">
								<p class="cb-tags"> <a href="https://www.futurelooks.com/tag/best-mechanical-keyboard/" rel="tag">best mechanical keyboard</a><a href="https://www.futurelooks.com/tag/corsair/" rel="tag">Corsair</a><a href="https://www.futurelooks.com/tag/corsair-gaming/" rel="tag">Corsair Gaming</a><a href="https://www.futurelooks.com/tag/gaming-keyboard/" rel="tag">gaming keyboard</a><a href="https://www.futurelooks.com/tag/k70/" rel="tag">K70</a><a href="https://www.futurelooks.com/tag/k70-mk-2/" rel="tag">K70 MK.2</a><a href="https://www.futurelooks.com/tag/mechanical-keyboard/" rel="tag">Mechanical Keyboard</a><a href="https://www.futurelooks.com/tag/mechanical-keyboard-2018/" rel="tag">mechanical keyboard 2018</a><a href="https://www.futurelooks.com/tag/rgb-mechanical-keyboard/" rel="tag">RGB Mechanical Keyboard</a><a href="https://www.futurelooks.com/tag/what-keyboard-to-buy/" rel="tag">what keyboard to buy</a></p><div class="cb-post-large cb-post-footer-block clearfix"><script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=835a55a1-5edd-43a8-8a57-e363f16e9e99"></script></div><div id="cb-previous-next-links" class="cb-post-footer-block clearfix"><div id="cb-previous-link"><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/"><i class="fa fa-long-arrow-left"></i></a><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/" rel="prev">Bloody Optical Keyboards: The New Mechanical Option?</a></div>                    <div class="cb-empty">No More Stories</div>
                </div><div id="cb-author-box" class="clearfix"><h3 class="cb-block-title">About The Author</h3><div class="cb-mask"><a href="https://www.futurelooks.com/author/alexlarente/"><img alt='' src='https://www.futurelooks.com/wordpress/wp-content/wphb-cache/gravatar/cb9/cb988e80d19a909296df98e58529d589x120.jpg' srcset='https://www.futurelooks.com/wordpress/wp-content/wphb-cache/gravatar/cb9/cb988e80d19a909296df98e58529d589x240.jpg 2x' class='avatar avatar-120 photo' height='120' width='120' /></a></div><div class="cb-meta"><div class="cb-info"><div class="cb-author-title"><a href="https://www.futurelooks.com/author/alexlarente/"><span>Alex Larente</span></a></div><div class="cb-author-contact"> <a href="http://www.larente.ca" target="_blank"><i class="fa fa-link cb-tip-bot" data-cb-tip="Website"></i></a>  <a href="https://www.instagram.com/alexlarente/" target="_blank" ><i class="fa fa-instagram cb-tip-bot" data-cb-tip="Instagram"></i></a></div></div><p class="cb-author-bio">Alex Larente has a passion for Online Digital Media, focused on Photography, Social Media, and Marketing. In his spare time, he enjoys playing video games, web development, and spending time with his family.</p></div></div><div id="cb-related-posts" class="cb-related-posts-block cb-post-end-block clearfix"><h3 class="cb-block-title">Related Posts</h3><ul>                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-1">
                                <div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/"><img title = "Futurelooks Bloody Optical Keyboards: The New Mechanical Option?  "width="360" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/07/bloody_b930-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt = "Bloody Optical Keyboards: The New Mechanical Option?  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/07/bloody_b930-360x240.jpg 360w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/07/bloody_b930-600x400.jpg 600w" sizes="(max-width: 360px) 100vw, 360px" /></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/">Bloody Optical Keyboards: The New Mechanical Option?</a></h4>
                                     <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-04">July 4, 2018</time></div></div>                                </div>
                            </li>
                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-2">
                                <div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-buys-elgato-gaming/"><img title = "Futurelooks Corsair Buys Elgato Gaming  "width="360" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/Screen-Shot-2018-06-27-at-3.20.02-PM-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt = "Corsair Buys Elgato Gaming  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/Screen-Shot-2018-06-27-at-3.20.02-PM-360x240.png 360w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/Screen-Shot-2018-06-27-at-3.20.02-PM-600x400.png 600w" sizes="(max-width: 360px) 100vw, 360px" /></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://www.futurelooks.com/corsair-buys-elgato-gaming/">Corsair Buys Elgato Gaming</a></h4>
                                     <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-30">June 30, 2018</time></div></div>                                </div>
                            </li>
                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-1">
                                <div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-hs70-wireless-gaming-headset-review/"><img title = "Futurelooks Corsair HS70 Wireless Gaming Headset Review  "width="360" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt = "Corsair HS70 Wireless Gaming Headset Review  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257-360x240.jpg 360w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257-650x433.jpg 650w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257-768x512.jpg 768w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257.jpg 1200w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257-600x400.jpg 600w" sizes="(max-width: 360px) 100vw, 360px" /></a><div class="cb-review-ext-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://www.futurelooks.com/corsair-hs70-wireless-gaming-headset-review/">Corsair HS70 Wireless Gaming Headset Review</a></h4>
                                     <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-21">June 21, 2018</time></div></div>                                </div>
                            </li>
                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-2">
                                <div class="cb-mask" style="background-color:#1e73be;"><a href="https://www.futurelooks.com/corsair-k63-wireless-mechanical-keyboard-review/"><img title = "Futurelooks Corsair K63 Wireless Mechanical Keyboard Review  "width="360" height="240" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180502-6901-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt = "Corsair K63 Wireless Mechanical Keyboard Review  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180502-6901-360x240.jpg 360w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180502-6901-650x433.jpg 650w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180502-6901-768x512.jpg 768w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180502-6901.jpg 1200w, https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180502-6901-600x400.jpg 600w" sizes="(max-width: 360px) 100vw, 360px" /></a><div class="cb-review-ext-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://www.futurelooks.com/corsair-k63-wireless-mechanical-keyboard-review/">Corsair K63 Wireless Mechanical Keyboard Review</a></h4>
                                     <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-05-10">May 10, 2018</time></div></div>                                </div>
                            </li>
</ul></div>
							</footer> <!-- end article footer -->

							
<div id="disqus_thread"></div>

						</article> <!-- end article -->

					
					
				</div> <!-- end #main -->

				<aside class="cb-sidebar clearfix" role="complementary">

<div id="advads_ad_widget-2" class="cb-sidebar-widget futur-widget"><div class="futur-1-sidebar-300-x-250" id="futur-1443295133"><div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FL Responsive Ad - Content -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5855561270035832"
     data-ad-slot="9604526707"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></div><div id="cb-popular-posts-4" class="cb-sidebar-widget widget-popular-posts widget-latest-articles"><h3 class="cb-sidebar-widget-title">Trending Posts</h3>
    		<ul class="cb-light cb-small">
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/new-apple-mac-pro-can-build-better-cheaper-pc-diy-style/"><img title = "Futurelooks The New Apple Mac Pro is Here - But Can We Build it Better (and Cheaper) PC DIY Style?  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2013/12/mac-pro-gallery1-2013-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "The New Apple Mac Pro is Here - But Can We Build it Better (and Cheaper) PC DIY Style?  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2013/12/mac-pro-gallery1-2013-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2013/12/mac-pro-gallery1-2013-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/new-apple-mac-pro-can-build-better-cheaper-pc-diy-style/">The New Apple Mac Pro is Here - But Can We Build it Better (and Cheaper) PC DIY Style?</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2013-12-19">December 19, 2013</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/45694-2/"><img title = "Futurelooks New GIGABYTE Laptops Will Have You Gaming on the Go at CES 2016  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/01/GIGABYTE-Skylake-CES-2016-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "New GIGABYTE Laptops Will Have You Gaming on the Go at CES 2016  " /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/45694-2/">New GIGABYTE Laptops Will Have You Gaming on the Go at CES 2016</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-01-10">January 10, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/intel-core-i7-6700k-skylake-processor-review/"><img title = "Futurelooks Intel Core i7-6700K &quot;Skylake&quot; LGA 1151 Processor Reviewed  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/09/Intel-Core-i7-6700K-Skylake-Processor-7-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Intel Core i7-6700K &quot;Skylake&quot; LGA 1151 Processor Reviewed  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">8.5</span><span class="cb-score-title"></span></div>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/intel-core-i7-6700k-skylake-processor-review/">Intel Core i7-6700K "Skylake" LGA 1151 Processor Reviewed</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2015-09-27">September 27, 2015</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/kingston-hyperx-savage-1866mhz-16gb-ddr3-memory-reviewed/"><img title = "Futurelooks Kingston HyperX Savage 1866MHz 16GB DDR3 Dual Channel Memory Kit Reviewed  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/12/Kingston-HyperX-Savage-16GB-18666-MHz-DDR3-Memory-12-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Kingston HyperX Savage 1866MHz 16GB DDR3 Dual Channel Memory Kit Reviewed  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/12/Kingston-HyperX-Savage-16GB-18666-MHz-DDR3-Memory-12-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2014/12/Kingston-HyperX-Savage-16GB-18666-MHz-DDR3-Memory-12-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9</span><span class="cb-score-title"></span></div>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/kingston-hyperx-savage-1866mhz-16gb-ddr3-memory-reviewed/">Kingston HyperX Savage 1866MHz 16GB DDR3 Dual Channel Memory Kit Reviewed</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-12-17">December 17, 2014</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/three-things-dont-like-far-windows-10/"><img title = "Futurelooks Five Things We Don&#039;t Like (So Far) About Windows 10  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Five Things We Don&#039;t Like (So Far) About Windows 10  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/three-things-dont-like-far-windows-10/">Five Things We Don't Like (So Far) About Windows 10</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-10-07">October 7, 2014</time></div></div>                                           </div>
                </li>
    		    		</ul>
    		</div>    <div id="advads_ad_widget-3" class="cb-sidebar-widget futur-widget"><div class="futur-3-sidebar-300-x-600" id="futur-389893626"><div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- FLRes300600SB -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5855561270035832"
     data-ad-slot="9981854702"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></div><div id="top-reviews-2" class="cb-sidebar-widget cb-top-reviews-widget"><h3 class="cb-sidebar-widget-title">Top Reviews</h3><ul>            <li class="cb-article cb-relative cb-grid-entry cb-style-overlay cb-dark-bg clearfix post-45042 post type-post status-publish format-standard has-post-thumbnail category-review tag-g1 tag-g1-series tag-ga-z170x-gaming-7 tag-ga-z170x-gaming-g1 tag-gaming tag-gaming-7 tag-gaming-gt tag-gigabyte tag-high-performance-award tag-lga1151 tag-motherboard tag-op-amp tag-recommended-award tag-skylake tag-z170 tag-z170x" >

                <div class="cb-mask"><a href="https://www.futurelooks.com/gigabyte-ga-z170x-gaming-7-ga-z170x-gaming-g1-motherboards-reviewed/"><img title = "Futurelooks GIGABYTE GA-Z170X-Gaming 7 and GA-Z170X-Gaming G1 Motherboards Reviewed  "width="400" height="250" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/10/GIGABYTE-GA-Z170X-Gaming-7-1-400x250.jpg" class="attachment-cb-400-250 size-cb-400-250 wp-post-image" alt = "GIGABYTE GA-Z170X-Gaming 7 and GA-Z170X-Gaming G1 Motherboards Reviewed  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/10/GIGABYTE-GA-Z170X-Gaming-7-1-400x250.jpg 400w, https://www.futurelooks.com/wordpress/wp-content/uploads/2015/10/GIGABYTE-GA-Z170X-Gaming-7-1-430x270.jpg 430w" sizes="(max-width: 400px) 100vw, 400px" /></a></div>
                <div class="cb-meta cb-article-meta">
                    <h4 class="cb-post-title h3"><a href="https://www.futurelooks.com/gigabyte-ga-z170x-gaming-7-ga-z170x-gaming-g1-motherboards-reviewed/">GIGABYTE GA-Z170X-Gaming 7 and GA-Z170X-Gaming G1 Motherboards Reviewed</a></h4>
                    <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-04-24">April 24, 2016</time></div></div>                </div>
                <div class="cb-countdown header-font">1</div>
                <div class="cb-review-ext-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title">Overall Score</span></div>                <a href="https://www.futurelooks.com/gigabyte-ga-z170x-gaming-7-ga-z170x-gaming-g1-motherboards-reviewed/" class="cb-link"></a>

            </li>
            </ul></div><div id="cb-recent-posts-2" class="cb-sidebar-widget widget-latest-articles"><h3 class="cb-sidebar-widget-title">Latest Posts</h3>
    		<ul class="cb-light cb-small">
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/"><img title = "Futurelooks The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/5aadahfkn-o-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/corsair-k70-mk2-keyboard-review/">The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-09">July 9, 2018</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/"><img title = "Futurelooks Bloody Optical Keyboards: The New Mechanical Option?  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/07/bloody_b930-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Bloody Optical Keyboards: The New Mechanical Option?  " /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/bloody-optical-keyboards-the-new-mechanical-option/">Bloody Optical Keyboards: The New Mechanical Option?</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-04">July 4, 2018</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/steelseries-rival-110-gaming-mouse-review/"><img title = "Futurelooks SteelSeries Rival 110 Gaming Mouse Review  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/20180630-7758-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "SteelSeries Rival 110 Gaming Mouse Review  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9</span><span class="cb-score-title"></span></div>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/steelseries-rival-110-gaming-mouse-review/">SteelSeries Rival 110 Gaming Mouse Review</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-07-02">July 2, 2018</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/corsair-buys-elgato-gaming/"><img title = "Futurelooks Corsair Buys Elgato Gaming  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/06/Screen-Shot-2018-06-27-at-3.20.02-PM-80x60.png" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Corsair Buys Elgato Gaming  " /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/corsair-buys-elgato-gaming/">Corsair Buys Elgato Gaming</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-30">June 30, 2018</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/corsair-hs70-wireless-gaming-headset-review/"><img title = "Futurelooks Corsair HS70 Wireless Gaming Headset Review  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2018/05/20180526-7257-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Corsair HS70 Wireless Gaming Headset Review  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9.5</span><span class="cb-score-title"></span></div>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/corsair-hs70-wireless-gaming-headset-review/">Corsair HS70 Wireless Gaming Headset Review</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2018-06-21">June 21, 2018</time></div></div>                                           </div>
                </li>
    		    		</ul>
    		</div>    
</aside>


			</div> <!-- end #cb-content -->

     			<footer id="cb-footer" class=" wrap" role="contentinfo">

    				<div id="cb-widgets" class="cb-footer-a cb-footer-wrap wrap clearfix">

                                                    <div class="cb-one cb-column clearfix">
                                <div id="rss-3" class="cb-footer-widget widget_rss"><h3 class="cb-footer-widget-title"><span><a class="rsswidget" href="https://www.megatechnews.com/feed"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.futurelooks.com/wordpress/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.megatechnews.com/">Headlines from MegaTechNews</a></span></h3><ul><li><a class='rsswidget' href='https://www.megatechnews.com/get-kindle-paperwhite-69-prime-exclusive/'>Get a Kindle Paperwhite for Only $69 (Prime Exclusive)</a> <span class="rss-date">July 10, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/apple-introduces-usb-restricted-mode-people-break/'>Apple Introduces USB Restricted Mode, People Break it</a> <span class="rss-date">July 10, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/cheaper-microsoft-surface-go-revealed-tomorrow/'>Cheaper Microsoft Surface Go to Be Revealed Tomorrow?</a> <span class="rss-date">July 9, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/beyond-0-entry-level-galaxy-s10-budget-conscious-users/'>Beyond 0: The Entry-Level Galaxy S10 for Budget-Conscious Users</a> <span class="rss-date">July 6, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/megatech-reviews-blackberry-key2-android-smartphone/'>MEGATech Reviews: BlackBerry KEY2 Android Smartphone</a> <span class="rss-date">July 6, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/first-gen-google-pixel-128gb-discounted-399/'>First-Gen Google Pixel 128GB Discounted to $399</a> <span class="rss-date">July 5, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/smaller-surface-tablet-come-much-less-powerful-chips/'>Smaller Surface Tablet to Come with Much Less Powerful Chips</a> <span class="rss-date">July 4, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/bluetooth-s-pen-galaxy-note-9-opens-new-possibilities/'>Bluetooth S-Pen for the Galaxy Note 9 Opens New Possibilities</a> <span class="rss-date">July 4, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/honor-10-gt-huaweis-first-8gb-ram-smartphone/'>The Honor 10 GT, Huawei&#039;s First 8GB RAM Smartphone</a> <span class="rss-date">July 4, 2018</span></li><li><a class='rsswidget' href='https://www.megatechnews.com/10-inch-microsoft-surface/'>Want a 10-Inch Microsoft Surface for $400? The Netbook Is Back?</a> <span class="rss-date">July 3, 2018</span></li></ul></div>                            </div>
                                                                            <div class="cb-two cb-column clearfix">
                                <div id="social-media-icons-3" class="cb-footer-widget cb-social-media-widget clearfix"><h3 class="cb-footer-widget-title"><span>Follow, Like and Subscribe!</span></h3><a href="http://twitter.com/futurelooks" rel="nofollow" target="_blank" class="cb-social-media-icon cb-twitter icon-1"></a><a href="http://facebook.com/futurelooks" rel="nofollow" target="_blank" class="cb-social-media-icon cb-facebook icon-2"></a><a href="http://www.youtube.com/futurelooksdotcom" rel="nofollow" target="_blank" class="cb-social-media-icon cb-youtube icon-3"></a></div><div id="mc4wp_form_widget-2" class="cb-footer-widget widget_mc4wp_form_widget"><h3 class="cb-footer-widget-title"><span>Awesome Newsletter</span></h3><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.2.4 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-48028 mc4wp-form-basic" method="post" data-id="48028" data-name="Futurelooks Newsletter" ><div class="mc4wp-form-fields"><p>
    <label>First Name</label>
    <input type="text" name="FNAME" required="">
</p>
<p>
    <label>Last Name</label>
    <input type="text" name="LNAME" required="">
</p>
<p>
  <label>Email address: </label>
	<input type="email" name="EMAIL" placeholder="Your email address" required />
</p>

<p>
	<input type="submit" value="Sign up" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1531307818" /><input type="hidden" name="_mc4wp_form_id" value="48028" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></div>                            </div>
                                                                            <div class="cb-three cb-column clearfix">
                                <div id="cb-popular-posts-3" class="cb-footer-widget widget-popular-posts widget-latest-articles"><h3 class="cb-footer-widget-title"><span>Popular Posts on Futurelooks</span></h3>
    		<ul class="cb-light cb-small">
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/new-apple-mac-pro-can-build-better-cheaper-pc-diy-style/"><img title = "Futurelooks The New Apple Mac Pro is Here - But Can We Build it Better (and Cheaper) PC DIY Style?  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2013/12/mac-pro-gallery1-2013-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "The New Apple Mac Pro is Here - But Can We Build it Better (and Cheaper) PC DIY Style?  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2013/12/mac-pro-gallery1-2013-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2013/12/mac-pro-gallery1-2013-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/new-apple-mac-pro-can-build-better-cheaper-pc-diy-style/">The New Apple Mac Pro is Here - But Can We Build it Better (and Cheaper) PC DIY Style?</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2013-12-19">December 19, 2013</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/45694-2/"><img title = "Futurelooks New GIGABYTE Laptops Will Have You Gaming on the Go at CES 2016  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2016/01/GIGABYTE-Skylake-CES-2016-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "New GIGABYTE Laptops Will Have You Gaming on the Go at CES 2016  " /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/45694-2/">New GIGABYTE Laptops Will Have You Gaming on the Go at CES 2016</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2016-01-10">January 10, 2016</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/intel-core-i7-6700k-skylake-processor-review/"><img title = "Futurelooks Intel Core i7-6700K &quot;Skylake&quot; LGA 1151 Processor Reviewed  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2015/09/Intel-Core-i7-6700K-Skylake-Processor-7-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Intel Core i7-6700K &quot;Skylake&quot; LGA 1151 Processor Reviewed  " /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">8.5</span><span class="cb-score-title"></span></div>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/intel-core-i7-6700k-skylake-processor-review/">Intel Core i7-6700K "Skylake" LGA 1151 Processor Reviewed</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2015-09-27">September 27, 2015</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/kingston-hyperx-savage-1866mhz-16gb-ddr3-memory-reviewed/"><img title = "Futurelooks Kingston HyperX Savage 1866MHz 16GB DDR3 Dual Channel Memory Kit Reviewed  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/12/Kingston-HyperX-Savage-16GB-18666-MHz-DDR3-Memory-12-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Kingston HyperX Savage 1866MHz 16GB DDR3 Dual Channel Memory Kit Reviewed  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/12/Kingston-HyperX-Savage-16GB-18666-MHz-DDR3-Memory-12-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2014/12/Kingston-HyperX-Savage-16GB-18666-MHz-DDR3-Memory-12-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a><div class="cb-review-ext-box cb-small-box"><span class="cb-bg" style="background:#1e73be;"></span><span class="cb-score">9</span><span class="cb-score-title"></span></div>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/kingston-hyperx-savage-1866mhz-16gb-ddr3-memory-reviewed/">Kingston HyperX Savage 1866MHz 16GB DDR3 Dual Channel Memory Kit Reviewed</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-12-17">December 17, 2014</time></div></div>                                           </div>
                </li>
    		
                <li class="cb-article clearfix">
                	<div class="cb-mask" style="background-color:#1e73be;">
                	    <a href="https://www.futurelooks.com/three-things-dont-like-far-windows-10/"><img title = "Futurelooks Five Things We Don&#039;t Like (So Far) About Windows 10  "width="80" height="60" src="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-80x60.jpg" class="attachment-cb-80-60 size-cb-80-60 wp-post-image" alt = "Five Things We Don&#039;t Like (So Far) About Windows 10  " srcset="https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-80x60.jpg 80w, https://www.futurelooks.com/wordpress/wp-content/uploads/2014/10/Futurelooks-Microsoft-Windows-10-Preview-What-We-Didnt-Like-3-160x121.jpg 160w" sizes="(max-width: 80px) 100vw, 80px" /></a>                	</div>
                    <div class="cb-meta">
                        <h4><a href="https://www.futurelooks.com/three-things-dont-like-far-windows-10/">Five Things We Don't Like (So Far) About Windows 10</a></h4>
                        <div class="cb-byline cb-font-header"> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time class="" datetime="2014-10-07">October 7, 2014</time></div></div>                                           </div>
                </li>
    		    		</ul>
    		</div>                                </div>
                                                
                    </div>

                    
                        <div class="cb-footer-lower clearfix">

                            <div class="wrap clearfix">

                                <div class="cb-copyright">Copyright 2017. Futurelooks.com / Futurelooks Media Inc.</div>

        						
           					</div>

        				</div>
    				
    			</footer> <!-- end footer -->

    		</div> <!-- end #cb-container -->

		</div> <!-- end #cb-outer-container -->

        <span id="cb-overlay"></span>

		<script>
		var advanced_ads_ga_UID = '';
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();		
		</script><script type='text/javascript'>var disqus_shortname = 'futurelooks'; // required: replace example with your forum shortname
                                (function () {
                                    var s = document.createElement('script'); s.async = true;
                                    s.type = 'text/javascript';
                                    s.src = '//' + disqus_shortname + '.disqus.com/count.js';
                                    (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
                                }());
                                </script><script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"futurelooks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/b4bfdb22-00c5-4ede-a0ba-4f4812763d30.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"49136 https:\/\/www.futurelooks.com\/?p=49136","disqusShortname":"futurelooks","disqusTitle":"The CORSAIR K70 MK.2 Mechanical RGB Gaming Keyboard Reviewed","disqusUrl":"https:\/\/www.futurelooks.com\/corsair-k70-mk2-keyboard-review\/","postId":"49136"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.futurelooks.com/wordpress/wp-content/uploads/hummingbird-assets/158928d2f5b4009cd5bd0deada723134.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/b972c148-bee0-4fd8-a5a9-8e68de38d217.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/a0d3d3ab-04ea-490d-914e-06bd1c32a746.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/5d735da2-6c97-46ef-aaaf-3eda806f1f7d.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/2b42f646-121f-4490-8b71-e184e846d8be.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/c3c2b695-7093-42a7-959b-ee5ca4f71b65.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/75766b93-6aac-4ac3-8322-44da71b1e70e.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/892836cc-51ec-412b-baf8-f0c38cf4ce09.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cbExt = {"cbSS":"on","cbLb":"on"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/afa7b777-1300-4dfe-9098-ca55119a98f3.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cbScripts = {"cbUrl":"https:\/\/www.futurelooks.com\/wordpress\/wp-admin\/admin-ajax.php","cbPostID":"49136","cbSlider":["600",true,"7000"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/f6b5ead6-716d-4e9e-a447-3effd22fff96.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/186408aa-3e5c-4a2e-b48e-2a1deba6713f.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackSlideshowSettings = {"spinner":"https:\/\/www.futurelooks.com\/wordpress\/wp-content\/plugins\/jetpack\/modules\/shortcodes\/img\/slideshow-loader.gif","speed":"4000"};
var jetpackSlideshowSettings = {"spinner":"https:\/\/www.futurelooks.com\/wordpress\/wp-content\/plugins\/jetpack\/modules\/shortcodes\/img\/slideshow-loader.gif","speed":"4000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/0d1a4738-1d77-409b-9dbb-c25223865ecd.js'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/ac17a822-2ab6-4e17-9b7d-d04137bd74a7.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/c2c670e4-95d5-464b-bbcd-425cb2937af2.js'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/adf714be-7fdc-42ae-b1fd-028b4976f92a.js'></script>
<![endif]-->
<script type='text/javascript' src='https://hb.wpmucdn.com/www.futurelooks.com/f7802c87-74db-415b-ac23-9358a44d7f6a.js'></script>

<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=ec775749-2f61-4bb9-adb3-603a20b53060"></script>

<script type="text/javascript">
  var vglnk = { key: 'eddc52af0657894b73e8a69b7961a197' };

  (function(d, t) {
    var s = d.createElement(t); s.type = 'text/javascript'; s.async = true;
    s.src = '//cdn.viglink.com/api/vglnk.js';
    var r = d.getElementsByTagName(t)[0]; r.parentNode.insertBefore(s, r);
  }(document, 'script'));
</script>

	<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"57c5db65b3","applicationID":"153531548","transactionName":"ZgZUZhNUWxIFVRFdDl9Md1EVXFoPS0UMWgZdBg==","queueTime":0,"applicationTime":2012,"atts":"SkFXEFtOSBw=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>

</html> <!-- The End. what a ride! -->
<!-- Page generated by LiteSpeed Cache 2.4 on 2018-07-11 04:16:58 -->